L'installation sur un système 32 bits nécessite la version i686 du kernel. Pour plus d'informations, vous pouvez vous rendre sur ce billet.

L'installation après avoir configuré le dépôt comme indiqué dans le billet est très simple:
yum install --enablerepo=drpixel kmod-gspca

The installation of the kmod-gpsca from this repository on a 32 bits version of Fedora Core 6 needs the i686 version of the kernel. You can find more information here

You can use install the package quite easily after you have configured the repository as explained on the link above. You only have to type :
yum install --enablerepo=drpixel kmod-gspca